CRTM install problem

I am trying to install crtmv2.4.0 on a linux environment. I got some problems.

When I try to build crtm using the following ‘make -j4’ command in ‘Build Step 1’, it said

‘CloudCoeff_netCDF_IO.f90(32): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [NETCDF]
USE netcdf
Screenshot 2022-08-19 at 8.41.06 PM

I checked that I have NETCDF installed and it is also in my environment variables.
I am confused and have no idea. Could someone help me?


Hello @cxzydn, welcome to the forum.

For the legacy build system, the netCDF directories are hard-coded in the configuration files in the configuration/ folder.
You may have to change the directories manually in the specific configuration file that you use.

This is one the reasons why we recommend using the new cmake build system instead.

1 Like

Hi, Dr. Stegmann. Thanks for your reply. It works ! :smile: :smile:

I also have a small question when using CRTM 2.4.0, that is how can I specify the cloud fraction overlap scheme in CRTM?

There’s a document (attached) that details how the cloud fraction scheme works.

See section 1.3



(Attachment Cloud_Fraction (1).pdf is missing)

I’m unable to attach the file here, but please send me an email at and I’ll reply with the file.

Hello @cxzydn,

To elaborate on Ben’s comment, you can set the cloud fraction overlap scheme with the CRTM Options type:

TYPE(CRTM_Options_type) :: opt(:)
! Set maximum-random overlap for cloud cover
CALL CRTM_Options_SetValue( opt, Set_MaxRan_Overlap = .TRUE. )

The available overlap schemes are listed here: CRTM Cloud Cover Definition