Jedi-bundle build failure on Orion

I am trying to build jedi-bundle on Orion with Intel compilers and am getting a build failure:

[ 83%] Built target fv3jedi_addincrement.x
/work/noaa/gsd-hpcs/charrop/SENA/JEDI/build/bin/fv3jedi_addincrement.x: symbol lookup error: /work/noaa/gsd-hpcs/charrop/SENA/JEDI/build/bin/fv3jedi_addincrement.x: undefined symbol: __libm_sindl_cosdl_table
make[2]: *** [fv3-jedi/src/mains/CMakeFiles/fv3jedi_addincrement.x.schema.json] Error 127
make[1]: *** [fv3-jedi/src/mains/CMakeFiles/fv3jedi_addincrement.x.schema.json.dir/all] Error 2
make: *** [all] Error 2
(base) charrop@Orion-login-4:/work/noaa/gsd-hpcs/charrop/SENA/JEDI/build> 

I’m not sure what the issue is and am wondering if anyone else has seen this.

My process:

module purge
module use /work/noaa/da/role-da/spack-stack/modulefiles
module load miniconda/3.9.7
module load ecflow/5.8.4
module load mysql/8.0.31

module use /work/noaa/epic-ps/role-epic-ps/spack-stack/spack-stack-1.4.0/envs/unified-env-v2/install/modulefiles/Core
module load stack-intel/2022.0.2
module load stack-intel-oneapi-mpi/2021.5.1
module load stack-python/3.9.7

module load jedi-fv3-env/unified-dev
module load ewok-env/unified-dev
module load soca-env/unified-dev

mkdir -p src
cd src
git clone
cd ..
mkdir -p build
cd build
ecbuild -DPython3_EXECUTABLE=$(which python3) ../src/jedi-bundle

make -j4

Hi Chris,

Jedi-bundle now uses CRTMv3. But CRTMv2.4.1 will be loaded when you load Spack 1.4.0. So after loading Spack 1.4 modules, you need to module unload crtm and then build the bundle.

I believe the infra team is working on solving this issue.

Hi @cwharrop, How’s it going? We have a temporary situation where we need to build CRTM v3 as part of the jedi-bundle. Make sure you have the latest jedi-bundle (jcsda-internal, develop branch) and then run module unload crtm after the module load statements. That should force CRTM v3 to be built as part of the bundle and that should make the build failure you reported go away.

We are doing it this way while we need to be able to switch back and forth between CRTM v2.4 and v3. After v3 gets established we will include v3 in the spack-stack and you won’t have to build CRTM as part of the bundle.


Thank you @maryamao and @stephenh. I am just now getting back to JEDI after a long absence and so am not up-to-date with everything. I tried making the change without redoing it all, but something wasn’t quite right so it didn’t work. Rather than messing around trying to sort that out I’ll try again from a clean slate and get back to you.

Can confirm that this worked exactly as expected. Thank you again for that important tip!