On orion how to use non-intel compiler to build jedi

Hi, folks,
How could I use non-intel compiler to build jedi?

Hi Ting,

You can use GNU based modules listed here: Using spack-stack modules to build and run JEDI — JEDI Documentation 5.0.0 documentation and on Spack Stack documentation: 3. Pre-configured sites — spack-stack 1.4.1 documentation

@maryamao Thank you so much!, I will do following the link you gave and give an update here!

1 Like

@maryamao An update: following the instructions given from where you pointed to, I have module loaded as

module purge
module use /work/noaa/da/role-da/spack-stack/modulefiles
module load miniconda/3.9.7
module load ecflow/5.8.4
module load mysql/8.0.31
module use /work/noaa/epic-ps/role-epic-ps/spack-stack/spack-stack-1.4.0/envs/unified-env-v2/install/modulefiles/Core
module load stack-gcc/10.2.0
module load stack-openmpi/4.0.4
module load stack-python/3.9.7
module load jedi-fv3-env/unified-dev
module load ewok-env/unified-dev
module load soca-env/unified-dev

But, after a couple of times trying on-off options in CMakeLists.txt , “ecbuild -DCMAKE_BUILD_TYPE=Debug -DMPIEXEC_EXECUTABLE=which srun -DMPIEXEC_NUMPROC_FLAG=”-n" …/" still gave the error messages as

-- The following OPTIONAL packages have not been found:

 * rttov (required version >= 12.1.0)
 * gsw
 * oasim
 * MKL
 * ropp-ufo

Are the modules with GNU a little behind compared with Intel ones? Any comments/suggestions are welcome!

I don’t see any error messages, these are optional packages that have not been found. Where’s the problem?

@climbfuji The ecbuild (cmake) complained it couldn’t find modules for those 5 sub-systems and gave the above error messages alongside " Configuring incomplete, errors occurred!" . I know some could be avoided , like ropp-ufo , I could let BUNDLE_SKIP_ROPP-UFO=OFF to let its’ own source created (but seems I have no permission to this branch and that would cause another error). But I failed to find options in the root CMakeLists.txt to avoid the above error messages for other 4 packages. Since the same jedi works with the intel module setup. I guess some differences in the GNU env caused this problem. Thanks.

@climbfuji Thanks a lot for your reminder. Yes. further searching in the output of the ecbuild , it was found the actual issue was with crtm , including issues like:

CMake Error at crtm/CMakeLists.txt:29 (add_subdirectory):
  add_subdirectory given source "src" which is not an existing directory.

Those issues had been reported by other developers and, hence, I just turned off options for use of crtm , which is not necessary for my work on orion for being now. The new building of JEDI using GNU succeeded after I also turned off l95.
Thanks a lot to both of you @maryamao @climbfuji